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Knowledge Base

  

Problem

While running the Exchange Management Console, you would receive the following message: 

The certificate status could not be determined because the revocation check failed.

You will see a status according to your version of exchange:

Exchange 2010:
Status: RevocationCheckFailure

Exchange 2007:
Status: Unknown


Nonetheless, if you click the Certificate Revocation List (CRL) specified on the certificate, you can still access the certificate provided by SSL247 through the Exchange server.


Cause

This problem appears because of the use of Windows HTTP Services (WinHTTP) by Exchange Server 2007/2010 to manage all HTTP and HTTPS traffic, and WinHTTP does not use the proxy settings that are configured for the Internet browser.

In order to display the WinHTTP proxy settings, at a command prompt, run this command:

netsh winhttp show proxy

 

Resolution


To solve the problem, the WinHTTP proxy setting and the server FQDN in the WinHTTP bypass list must be configured.

Note: If both the proxy setting and the server FQDN in the WinHTTP bypass list are not configured, the Exchange Management Shell and the Exchange Management Console & the Remote PowerShell cannot be connected.


To solve this problem, open a command prompt, then execute the following command and press ENTER:

netsh winhttp set proxy proxy-server="http=myproxy" bypass-list="*.host_name.com"

The myproxy placeholder indicates the proxy server name, and host_name indicates the Exchange Server 2010 host name.


P.S.: If no proxy is used, please type the following command to restore the default values:

netsh winhttp reset proxy
netsh winhttp reset tracing

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