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Knowledge Base

  

Problem

The error occurs when connecting. You are unable to connect to Certificate. IKEYMAN does allow changing the friendly name

"Could not find Certificate in key database"


Cause

When the keys were created a "friendly name" with brackets was specified. As long as there was only one certificate installed in the key.kdb, the brackets in the friendly name did not cause issues. 
When multiple SSL enabled virtual hosts were added, the server would not recognise the friendly name with the brackets.


Resolution

To resolve this issue, you will need to use OpenSSL. Please use the following process to recreate the private key and Certificate with a new friendly name without brackets:

1. Export the private key and Certificate in PKCS#12 format with IKEYMAN.

2. Convert into a pem-file: openssl pkcs12 -in YourOriginalpkcs12.p12 -out Work.pem
(you need to provide the private key's export password and a PEM password)

3. Recreate the pkcs12 file with a new friendly name: openssl pkcs12 -export -in Work.pem -out newpkcs12.p12 -name Newfriendlyname

4. Make a backup of your key database (tar -cvf keydb_date.tar key).

5. Open IKEYMAN then Delete the original private key/Certificate.

6. Import the modified pkcs12 file.

It will appear the new friendly name 'Newfriendlyname'

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